LabTech Support Forums

Can't run scripts against groups with limit by of new search

This forum is for discussion of search related issues.

Moderator: jware.connectwise

Can't run scripts against groups with limit by of new search

Postby teamits » Tue Nov 01, 2016 12:11 pm

A heads up on something that I'm told is "by design"...if you create a new search and try to run a script on a group with a "limit by" of the new search, it may not work. LabTech apparently runs the searches in the background instead of doing it at the time of script launch. If that process hasn't happened yet it won't find any members so won't run on the group.

"This is working as designed. Searches and group joins happen on a schedule. You can manually kick them off if needed sooner. Basically the issue is that when you create a search it is added to the SensorCheck table. When the searches loop happens it runs all the searches in the SensorChecks table and puts the results in the Searches table. All groups, limit to filters, etc all use the results that are in the Searches table to run against.

So it appears that doing a [Help/Server Status/] Do Group Refresh and allowing it to complete would be necessary on any search creation/change you make prior to using it as a limit-to."

Alternatively, waiting 30 (24?) minutes after creating a search should work also.
Steve
teamits
Hero Member
Hero Member
 
Posts: 1566
Joined: Wed Dec 31, 1969 8:00 pm

Return to Searches

Who is online

Users browsing this forum: No registered users and 1 guest

cron