LabTech Support Forums

Labtech with Office365

This forum is for discussion of Email related issues.

Moderator: jware.connectwise

Labtech with Office365

Postby michael.anchornetworksolutions » Tue Feb 04, 2014 1:33 pm

I am attempting to get email working with an Office365 account, but so far been unsuccessful. What settings do I need to review in Labtech? Anything special that I need to setup in Office365?
michael.anchornetworksolutions
Newbie
Newbie
 
Posts: 5
Joined: Tue Feb 04, 2014 1:31 pm

Re: Labtech with Office365

Postby mkeigher.choicesolutions » Wed Feb 05, 2014 7:45 pm

Hello Michael and Welcome to the forums!

I also had the same issues with Office 365, and the reason why it wont work is that LT has issues (or it's just not setup to work) with TLS encryption. So.. what you need to do is setup the SMTP feature on your LT server and configure your LT Mail setup to point to itself for SMTP relay.

So... to set this up, do the following:

1) http://support.microsoft.com/kb/2600912. Hate to state the obvious, but... You do NOT need to do Step 1: Install Internet Information Services (IIS) from the guide, as it's already on your server from the LT install, BUT [for Server 21012/R2] do make sure that the "Basic Authentication" role/feature is enabled under IIS > Web Server > Security! ;)

2) Go into services.msc and make sure that SMTP service is set to Automatic, and STOP the service.

3) Restart the IIS Admin service and then START the SMTP Service.

4) Configure your LT Mail Setup (Dashboard > Config > System) similar to the screenshot:

Image
FYI: 10.20.92.15 is the LocalIP of my LT (and now) SMTP server.

5) TEST TEST and TEST again!

PS: NO reboot is required during this process!
PPS: Restart DBAgent to Reload DB properties (Dashboard > Config > Config > Properties) to give it a kick, if it needs it!

Oh... and another tip! :) Be sure you have the EmailFromName property set too (under Dashboard > Config > Config > Properties) as SOME mail filters WILL BLOCK your emails if they don't detect a From Name, *especially* when going via O365! (I learnt that the hard way, of course! :roll: )

Image

To summarize:

LabTech sends emails to an SMTP server on port 25, and then the SMTP server sends the email to Office 365 on port 587, as LT can't send on 587 itself.

Regards,
Martyn T. Keigher - Managed Services Professional
Choice Solutions LLC


Join us in the ##labtech IRC channel @ http://bit.ly/WeDMb8.
- The channel created by LabTech users for LabTech users!

Image
User avatar
mkeigher.choicesolutions
Sr. Member
Sr. Member
 
Posts: 271
Joined: Tue Oct 11, 2011 2:03 am

Re: Labtech with Office365

Postby rfaughnan.labtechsoftware » Tue Feb 11, 2014 11:24 am

To get this to work you need to ensure you enable SMPTSSL within labtech using the below process. Once you do that Labtech will be able to send email with Office365 with no issue.

Go to your DASHBOARD > CONFIG > CONFIGURATIONS > PROPERTIES
Add a new entry with a name of SMTPSSL and a value of TRUE
Save the new entry.

After this make sure to restart the Labtech Database Agent service on your labtech server.
Robert Faughnan
LabTech Software Support
rfaughnan.labtechsoftware
Newbie
Newbie
 
Posts: 8
Joined: Thu Jun 13, 2013 12:52 pm

Re: Labtech with Office365

Postby mkeigher.choicesolutions » Tue Feb 11, 2014 2:21 pm

I tried that and it still didn't work, but oh well... It's working (the long way around) for me now!!

On the plus side... My ESET server is in the same DMZ as my LT server and it uses my LT server as it's SMTP too.


Sent from my iPhone using Tapatalk
Martyn T. Keigher - Managed Services Professional
Choice Solutions LLC


Join us in the ##labtech IRC channel @ http://bit.ly/WeDMb8.
- The channel created by LabTech users for LabTech users!

Image
User avatar
mkeigher.choicesolutions
Sr. Member
Sr. Member
 
Posts: 271
Joined: Tue Oct 11, 2011 2:03 am

Re: Labtech with Office365

Postby ljones.connectwise » Thu Jul 21, 2016 6:21 pm

Office 365 requires specific ports - 25 for SMTP won't work.

See KB:

https://docs.labtechsoftware.com/knowle ... ticle/6882


for list of the ports and property settings required
ljones.connectwise
Newbie
Newbie
 
Posts: 2
Joined: Tue Jul 05, 2016 11:39 am


Return to Email

Who is online

Users browsing this forum: No registered users and 2 guests

cron